最新消息內容

LD
[漏洞預警]Apache Struts 2.3.X系列版本中的Showcase應用程式存在讓攻擊者遠端執行任意程式碼之漏洞(CVE-2017-9791),請儘速確認並進行修正


發佈日期
17-07-19
公告人員
曾國旭

[內容說明:]
轉發行政法人國家資通安全科技中心 資安訊息警訊 NCCST-ANA-201707-0004
Apache Struts 2是一個開放原始碼的Java EE網路應用程式的Web應用框架。
該漏洞主要是在Apache Struts 2.3.X系列版本啟用Struts 2 Struts 1外掛(struct2-strust1-plugin.jar)環境下,Showcase應用程式(struct2-showcase.war)呼叫struct2-strust1-plugin時,攻擊者利用傳遞含有惡意字串的內容,造成可遠端執行任意程式碼。

[影響平台:]
Apache Struts 2.3.X的版本

[建議措施:]
1.請確認網站主機是否使用Apache Struts 2 的Web應用框架,若有使用則可再透過網站主機目錄中的「WEB-INFlib」資料夾內的Struts.jar檔確認當前使用的版本。
2.請確認網站主機是否使用Apache Struts 2的Showcase應用程式,路徑:struts2.3.xappsstruts2-showcase.war。
3.如所使用的Apache Struts為上述(2.3.X)受影響之版本,則請更新官方網頁或官方Github所釋出最新之Apache Struts 2.5.10的版本。
4.若無使用的需求,請關閉Showcase應用程式。

[參考資料:]
1. https://cwiki.apache.org/confluence/display/WW/S2-048
2. http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9791